poloniumv's

Запуск X11 приложений по сети

6 февраля 2017 г. 13:12

Понадобилось как-то на выходных запустить приложение на рабочей машине, но так чтоб из дому, без похода к офису, да и так чтоб отрисовывалось оно на экране домашнего ПК.

Благо, OpenVPN настроен, IP своей рабочей станции знаю, sshd на ней запущен. Осталось всего ничего.

Качаю PuTTY, Xming и необходимые для него шрифты и устанавливаю все это добро.

PuTTY. Указываю IP удаленной рабочей станции и порт на котором висит sshd:

Перехожу в раздел Connection → SSH → X11, включаю "Enable X11 forwarding" ...

OpenVPN на Arch Linux

3 февраля 2017 г. 10:38

Когда надо заиметь доступ в локальную сеть извне, скажем, с сети другого провайдера, например, на помощь приходит OpenVPN. Установка нехитрая и много времени не займет.

Ставим, собственно, сам openvpn и тулкит для генерации сертификатов и ключей безопасности:

sudo pacman -S openvpn easyrsa

Приступаем к генерации ключей и сертификатов. Создаем рабочий каталог и тянем в него необходимые для генерации файлы:

mkdir ~/easyrsa
cp -r /etc/easyrsa/x509-types ~/easyrsa/
cp /etc/easyrsa/openssl-1.0.cnf ~/easyrsa/
cd ~/easyrsa

Создаем инфраструктуру публичных ключей ...

Ноутбук с CentOS как точка доступа

26 мая 2014 г. 11:31

После приобретения смартфона возникла идея использовать Wi-Fi карту рабочего ноутбука (Qualcomm Atheros AR242x / AR542x Wireless Network Adapter) как точку доступа. Дело нехитрое.

Ставим dhcpd:

yum install dhcp

Правим конфиг /etc/dhcp/dhcpd.conf. У меня он выглядит так:

default-lease-time 3600;
max-lease-time 9000;
authoritative;
log-facility local7;
subnet 192.168.11.0 netmask 255.255.255.0 {
    interface wlan0;
    range 192.168.11.2 192.168.11.255;
    option domain-name-servers 95.169.2.106;
    option routers 192.168.11.1;
    option broadcast-address ...

Передача BGP-префиксов на Cisco

13 апреля 2012 г. 12:40

Дано: два апстрима, от одного из которых я принимаю full-view (World), от второго только украинские префиксы (UA).
Задача: отдать default route и, отдельно, украинские префиксы пиру Target и принять и проанонсить его префиксы аплинкам. Украинский трафик, естественно, должен ходить через UA, остальной через World.

Решение:

interface GigabitEthernet1/1
 switchport
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 10
 switchport mode trunk
 switchport nonegotiate
!
interface GigabitEthernet1/2
 switchport
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 20
 switchport mode trunk
 switchport ...
1