poloniumv's

Обновление IOS через tftp

1 августа 2012 г. 14:45

Привезли маршрутизатор Cisco 2811 и дали указание залить более новый IOS. Ок, сделаем. Поднял на ноутбуке (стоит xubuntu 11.04) tftp-сервер:

sudo apt-get install tftpd-hpa

Потом привел /etc/default/tftpd-hpa в такой вид:

TFTP_USERNAME="tftp"
TFTP_DIRECTORY="/var/lib/tftpboot"
TFTP_ADDRESS="10.0.1.195:69"
TFTP_OPTIONS="-p -v -v -v -c -s" 

Дальше перезапустил tftpd:

sudo /etc/init.d/tftpd-hpa restart

На самом маршрутизаторе поставил IP-адрес из своей внутренней сетки:

2811#conf t
2811(config)#int Fa0/0 ...

Передача BGP-префиксов на Cisco

13 апреля 2012 г. 12:40

Дано: два апстрима, от одного из которых я принимаю full-view (World), от второго только украинские префиксы (UA).
Задача: отдать default route и, отдельно, украинские префиксы пиру Target и принять и проанонсить его префиксы аплинкам. Украинский трафик, естественно, должен ходить через UA, остальной через World.

Решение:

interface GigabitEthernet1/1
 switchport
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 10
 switchport mode trunk
 switchport nonegotiate
!
interface GigabitEthernet1/2
 switchport
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 20
 switchport mode trunk
 switchport ...

Ограничение скорости внутри VLAN на Cisco

13 апреля 2012 г. 11:27
mls qos
class-map match-any CustomerVLAN
 match access-group name customer-policy_inbound
 match access-group name customer-policy_outbound
!
policy-map VLAN-policy
 class CustomerVLAN
  police 1000000000 conform-action transmit exceed-action drop violate-action drop
!
interface Vlan10
 description Customer
 ip address x.x.x.x x.x.x.x
 mls qos bridged
 service-policy input VLAN-policy
 service-policy output VLAN-policy
!
interface TenGigabitEthernet4/1
 description Trunk
 switchport
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 10
 switchport mode trunk
 mls qos vlan-based
! 

 

BGP и два канала

5 апреля 2011 г. 12:53

К одной удаленной точке, которая была доступна только по WiFi, появился 100 Мбит/с канал. Решили сделать так, чтобы при падении 100 Мбит/с канала связь переруливалась на WiFi, а при восстановлении - все переруливалось обратно (т. к. пользователям той удаленной точки мы предоставляем интернет). С обеих сторон стоят циски, есть небольшой пул "белых" IP-адресов.
Первым делом задал два default-маршрута с разной метрикой:

ip route 0.0.0.0 0.0.0.0 A.B.C.73
ip route 0.0 ...
1