poloniumv's

Запуск Django-проекта на nginx с gunicorn в Arch Linux и с БД PostgreSQL

1 февраля 2017 г. 13:27

Первым делом ставим виртуальное окружение

sudo pacman -S python2-pip
sudo pip2 install virtualenv virtualenvwrapper
mkdir ~/Env
echo "export WORKON_HOME=~/Env" >> ~/.bashrc
echo "export VIRTUALENVWRAPPER_PYTHON=/usr/bin/python2" >> ~/.bashrc
echo "source /usr/bin/virtualenvwrapper.sh" >> ~/.bashrc
source ~/.bashrc
mkvirtualenv firstsite

Из-под виртуального окружения (в которое мы попадаем после mkvirtualenv) ставим необходимые модули и создаем Django-проект:

pip install django psycopg2 gunicorn
cd ~
django-admin startproject firstsite

Далее правим настройки проекта:

nano ~/firstsite/firstsite/settings.py
# ...
ALLOWED_HOSTS = ['доменные_имена', 'и/или_ip-адрес_проекта']
# ...
DATABASES ...

Несколько версий PHP на Apache2 в Arch Linux

1 февраля 2017 г. 12:10

Третьего дня понадобилось перенести несколько веб-сайтов с довольно старой машины на более новую. Часть сайтов с ходу не завелась, т. к. писалась еще за царя Панька. Да и искать того кто писал и просить исправить, дабы на новой версии PHP работало, бессмысленно. Поэтому, собственно, сабж.

Собираем старую версию php (мне надо была 5.4):

yaourt -S php54

Доставляем к основному php (у меня версии 7) cgi-модуль и FastCGI-модуль для Apache2:

sudo pacman -S php-cgi mod_fcgid

Создаем каталог для fcgi-файлов и ...

Получение root-прав на планшете с Rockchip RK3066

7 мая 2015 г. 16:04

Некоторое время назад приобрел планшет Mystery MID-722 и, естественно, столкнулся с недостатком места на внутреннем накопителе. Дополнительная SD-карта для музыки, видео, книг и всякого такого пригодилась, но вот кэш и данные программ на нее не поместишь просто так (внутрення карта монтировалась как /mnt/sdcard, внешняя же как /mnt/external_sd). Любой из способов, будь то перемонтирование/симлинки/изменение fstab, требовал наличия root-прав.
Никакое из приложений для самого устройства результата никакого не принесли. Решено было подключить планшет к компьютеру, включить отладку через ...

Ноутбук с CentOS как точка доступа

26 мая 2014 г. 11:31

После приобретения смартфона возникла идея использовать Wi-Fi карту рабочего ноутбука (Qualcomm Atheros AR242x / AR542x Wireless Network Adapter) как точку доступа. Дело нехитрое.

Ставим dhcpd:

yum install dhcp

Правим конфиг /etc/dhcp/dhcpd.conf. У меня он выглядит так:

default-lease-time 3600;
max-lease-time 9000;
authoritative;
log-facility local7;
subnet 192.168.11.0 netmask 255.255.255.0 {
    interface wlan0;
    range 192.168.11.2 192.168.11.255;
    option domain-name-servers 95.169.2.106;
    option routers 192.168.11.1;
    option broadcast-address ...

Бэкап музыки vk.com

17 июля 2013 г. 14:12

Нашел замечательный скрипт на Python'е, при помощи которого можно сделать бэкап "Моих Аудиозаписей" в социальной сети vk.com.

Для того чтобы им воспользоваться необходимо:
1. иметь незаблокированную учетную запись;
2. создать standalone-приложение (если такового нет).

После запуска скрипт запросит логин, пароль и AppID. Если введенная информация верна - скрипт начнет бэкапить музыку.

yandex.Диск и Linux (xubuntu)

17 июля 2013 г. 8:50

Я, вообще-то, не любитель всяких и разных облачных сервисов, онлайн-хранилищ и тому подобного, но решил попробовать сабж. Зарегистрировался в Яндексе и получил 3 гигабайта места под хранение всякого хлама.
Дабы примаунтить его необходимо поставить davfs2:

sudo apt-get install davfs2

Создать каталог для, собственно, монтирования:

sudo mkdir /media/<username>/yandex 

Дополнить /etc/fstab подобной строкой:

https://webdav.yandex.ru /media/<username>/yandex davfs uid=pv,file_mode=640,dir_mode=755,user,noauto 0 0 

Указать логин/пароль для Яндекс-диска в /etc ...

Обновление IOS через tftp

1 августа 2012 г. 14:45

Привезли маршрутизатор Cisco 2811 и дали указание залить более новый IOS. Ок, сделаем. Поднял на ноутбуке (стоит xubuntu 11.04) tftp-сервер:

sudo apt-get install tftpd-hpa

Потом привел /etc/default/tftpd-hpa в такой вид:

TFTP_USERNAME="tftp"
TFTP_DIRECTORY="/var/lib/tftpboot"
TFTP_ADDRESS="10.0.1.195:69"
TFTP_OPTIONS="-p -v -v -v -c -s" 

Дальше перезапустил tftpd:

sudo /etc/init.d/tftpd-hpa restart

На самом маршрутизаторе поставил IP-адрес из своей внутренней сетки:

2811#conf t
2811(config)#int Fa0/0 ...

Подвисшие PPtP-сессии в mpd5

24 июля 2012 г. 12:56

После перезагрузки сервера, на котором установлены mpd5 и FreeRADIUS, клиентам, которые коннектятся по PPtP начала вылетать ошибка 691, при том, что логин/пароль и параметры безопасности были введены правильно. В radius.log'е была куча таких сообщений:

Tue Jul 24 10:34:33 2012 : Auth: Multiple logins (max 1) [MPP attempt]: [vpnlogin/] (from client localhost port 4 cli )

Похоже, подвисли сессии. Решилось просто: командой radwho получил список сессий, а командой radzap их прибил. После этого все стало хорошо :)

Передача BGP-префиксов на Cisco

13 апреля 2012 г. 12:40

Дано: два апстрима, от одного из которых я принимаю full-view (World), от второго только украинские префиксы (UA).
Задача: отдать default route и, отдельно, украинские префиксы пиру Target и принять и проанонсить его префиксы аплинкам. Украинский трафик, естественно, должен ходить через UA, остальной через World.

Решение:

interface GigabitEthernet1/1
 switchport
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 10
 switchport mode trunk
 switchport nonegotiate
!
interface GigabitEthernet1/2
 switchport
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 20
 switchport mode trunk
 switchport ...

Ограничение скорости внутри VLAN на Cisco

13 апреля 2012 г. 11:27
mls qos
class-map match-any CustomerVLAN
 match access-group name customer-policy_inbound
 match access-group name customer-policy_outbound
!
policy-map VLAN-policy
 class CustomerVLAN
  police 1000000000 conform-action transmit exceed-action drop violate-action drop
!
interface Vlan10
 description Customer
 ip address x.x.x.x x.x.x.x
 mls qos bridged
 service-policy input VLAN-policy
 service-policy output VLAN-policy
!
interface TenGigabitEthernet4/1
 description Trunk
 switchport
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 10
 switchport mode trunk
 mls qos vlan-based
!